Creative Inspire 6700 speakers

  rog48 20:23 19 Jan 04
Locked

Bought new system 11 months ago from Multivision.
Just decided to contact them before 12 months were up, as the speakers have been faulty from the off (never got round to telling them). Horrified to see they are no longer trading (bought my daughter a laptop from them last Oct, as well).
Anyway, the fault with the speakers is intermittent, hence not desperate to replace. At times there seems to be crackling interference, along with very loud bangs, like gunshots (very frightening at times). Have tried unplugging each speaker in turn, it seems to be the subwoofer that is causing the problem. My question is, has anyone else had this problem, or heard of it, or can anyone offer any advice?

  A.J.P. 19:36 20 Jan 04

rog48

This is a known problem with the Creative 6700 speakers. A faulty power supply when they 1st came out meant that Creative had to replace either the power supply adapter &/or subwoofer on all of the first customers. The power supply was damaging the sub & cutting in & out, hence the loud popping.

Creative were happy to send out the replacements to all customers who logged the problem with themn via their web-site - I had a new sub & a new power supply adapter & this fixed the problem. I will look up the details & post them soon. Hopefully they can sort you out very quickly. This problem was affecting so many customer that at one stage it looked like they were going to have a riot on their hands, but they were very fast in sorting it all out & keeping everyone happy.

AJP.

  Gaz 25 20:08 20 Jan 04

AJP is correct!

And they had a recent problem with the Megaworks.

Anyway, see their website click here


Regards,
Gareth

  A.J.P. 20:11 20 Jan 04

rog48

Here is a link to a 45 page thread on the Creative Support Forum regarding the 6700 popping problem.

click here

To get replacements (didn't have to send old sub & psu back) I emailed [email protected] with the following details:

Name
Address
Phone Number
Serial Number of the speakers (found on base of sub & side of box)
Date & from where I purchased them.
Details of the problem.

They emailed back & sent out replacements. Hopefully they will sort you out (they are used to it on the 6700s).

Good luck (its definitely worth doing),
AJP.

  rog48 20:46 20 Jan 04

Wow,
never realised I was part of a much bigger player. Thought this problem was unique to me-Ha
Have e-mailed and await their response.
Thanks to you all for the info
Rog

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…