Camera Fault

  Declanworld 18:38 19 Feb 08
Locked

My Canon S3 IS has displayed 'Lens error, restart camera' on two occasions - both outdoors on long walks.

Canon told me that the camera needed servicing and, within warranty, I sent the camera to their service centre in Glasgow.

Glasgow posted the camera back with the 'No fault found' message.

I know this camera's going to play up the next time I go on my walk and that the issue only occurs via either cold or humidity or both.

Any words of advice?

  Arnie 18:58 19 Feb 08

It seems that some of the Canon models suffer from this problem.

The following is an extract from this site:

click here

Update: I have heard that Cannon has changed the name of the error on newer cameras from E18 to simply "Lens Error" or "Lens Error, Restart Camera". It is believed that this is very similar to the E18 error. Please let us know if you are having this error.

Also try this site:

click here

  amonra 19:49 19 Feb 08

click here

Have a look at this site. Canon have had quite a few problems with the lens system on certain cameras. Suggestions for a temporary cure range from blowing the lens area with compressed air, to gently tapping the camera on a table top !
Good luck !

  jack 19:57 19 Feb 08

Keeping the camera warm in your clothing clothing is a possible remedy

  Declanworld 22:40 19 Feb 08

Thanks everyone for the great info and links.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…