WiFi connection intermittent- "no IP address"

  HarryTanner 00:12 08 May 15
Locked

When trying to connect to the WiFi network, the password is repeatedly asked for, and when inputted, is said to be incorrect (please note the Wifi works perfectly on all of our other devices).

At the Network preferences menu, the wifi hub is selected. It begins to connect for a short amount of time, before asking for the password.The inputted password is flagged as incorrect, and "no IP address" is shown under the wifi option on the left.

We have reset the operating system to try to solve the problem. We have also tried manually inputting the IP address shown under the ethernet section, but nothing has worked.

If anybody has experienced a similar situation or has any ideas, please reply. Thanks

2010 Macbook Pro OSX Yosemite v.10.10.3

  bremner 10:57 08 May 15

Does the machine connect properly over Ethernet?

  HarryTanner 12:56 08 May 15

Yes, ethernet works perfectly.

  HondaMan 19:56 09 May 15

I think I read somewhere that this is a bug in Yosemite which Apple are addressing. Search the various forums for the answer. I also have this problem but it seems to cure itself over time

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This stop-frame animation tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…