unable to get Amacom IOdisk to be recognised

  terendak_uk 19:44 25 Jul 04

It's an USB2 ext HD. Got WinXPHome. USB1-PCI. Connect the external IO HD and get the usual mass storage disc found, searching for...then info message stating that I'm trying to connect a USB2 device to USB 1. Then....nothing. Drive not recognised( AMacom state no drivers reqd)....checked in Control P and have exclamation mark by USB storage device. Amacom clearly state that this device is backwards-compatible. Any ideas would be gratefully received. Green light on HD is on. Tried other cables and various connections eg via monitor USB connectors( external power source)with same results. Defective drive?

  terendak_uk 20:50 02 Aug 04

will ring Amacom. Even plugged it into my USB Hispeed PCI card ( actually much better for flatbed scanspeed than USB1)with same result. Bought a Lacie ext HD since...so far, so good.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…