Repair for an out of warranty machine.

  Daz35 15:27 14 Mar 05
Locked

This is not quite as simple as it seems.

I bought the PC in November 2003 from PC World. In November 2004, a week before the warranty was due to run out, the PC started to switch itself off for no apparant reason, so I rang PC service call and went through the normal procedures with them and they diagnosed the problem being with the motherboard.

The engineer came, replaced the mobo and it worked fine.

83 days later, excatly the same problem happened, machine just switching itself off for no reason. I called PC service call and they booked an engineer to replace the mobo again.

The problem now is that the machine is out of warranty, but they give you a 90 day warranty on the part/repair.

So engineer comes out, fits mobo number 3, it all works when he tests it, great I think. After he left I hook my router and modem back up only yo find the ethernet connection doesn't work. I changed cables around etc, but to no avail.

Back on the phone to PC service call, another engineer and mobo number 4. The person I spoke to then told me that they really needed the machine to be picked up to be looked at, but couldn't do that cos it' out of warranty.

So next engineer comes 2 days later and actually tells me he doesn't think it's the mobo that's the problem. (but doesn't know what is).

This works for a week and then the same problem happens again - machine just switching off (with activity light staying on).

This time when I phone PC service call, the man in the call centre tells me it will be picked up by courier today, and they will contact me to let me know what time.

No call this morning, so I rang them again, to be told there has been a cock up and they can't pick the PC up, as it's out of warranty.

So, I'm not happy, having spent hours on the phone and in the garage finding the original packaging to send it back as well as waiting in for a courier who wasn't coming.

They are now sending another engineer out on Wednesday to replace the mobo again, even though this quite obviously is not solving the problem.

I'm at my wits end to know what to do. All they seem to do is pass the buck. The guy today told me that if they can't fix the machine in 28 days, the store will replace it.

But....., he says the fact that it worked for almost 90 days doesn't count. It's only from the time I booked an engineer in February, and that will be 28 days next week.

I then have to go to the store where I bought it and sort it out there, but I know all they're going to say is that it's out of warranty, so they can't replace it.

The fact of the matter is, that the problem which hasn't been fixed occured when the machine was in warranty, but now it isn't.

Does anyone know what I should now do, as I'm getting rather confused with what rights I have in regard to this.

  mattyc_92 15:37 14 Mar 05

I would think that because you reported this problem during the warranty and it still isn't fixed, then the problem is like they took your system and they haven't gave it back to you yet as they haven't fixed the problem...

I am probably wrong, but I think that they should repair/replace the system as they haven't repaired the problem that you explained to them during the warranty....

  Daz35 15:47 14 Mar 05

The trouble is, is that they are offering to fix the problem, but just keep offering to do the same thing (replace the mobo), even though this doesn't fix the original problem.

  woodchip 15:56 14 Mar 05

My guess is try a new PSU

  mattyc_92 16:00 14 Mar 05

Ask them if they would do a dianostic on the hardware and software to see if there is a problem...

  Completealias 16:02 14 Mar 05

Maybe others in the consumerwatch forum may no better but i would think that because you reported the fault b4 your warranty expired then the company should b liable for fixing the fault by whatever means.

Keep a record of calls for a start eg when you first reported it and what actions they have taken incase you get into a dispute with pc world or service call.

  Daz35 16:06 14 Mar 05

Woodchip,

They mentioned this, but the engineer didn't bring one with him.

One thing I've just noticed is that just before it turns off the network connection monitor icon pops up and says 'a network cable is unplugged', and then it goes off.

When the engineer put the 3rd mobo in the ethernet didn't work at all, so could it be related to that? (The lan is on board, not a separate card.)

mattyc_92

Yep, they've tried that!

  Daz35 16:09 14 Mar 05

Completealias

Good advice, and in fact I have already emailed pc service call to ask for a record of calls and engineer visits etc.

I have got approx dates written down, but am going to write to Mastercare and need to be precise.

  mattyc_92 16:09 14 Mar 05

Thats what I mean

  woodchip 16:12 14 Mar 05

Well as you are using a computer to post can you unplug the Cables, put the other alongside and plug the PSU plugs to that one

  Daz35 16:30 14 Mar 05

I've changed the ethernet cables round and they are fine on the laptop (got laptop and main PC on a network using a router).

Don't think I can do what you're suggesting with a laptop?

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…