Macromedia Director 3D help,

  Mysticnas 21:14 19 Jan 04
Locked

Hiya all,

posted this on some other more appropriate forums but just incase someone here knows anything...

I'm using Director MX and have imported some 3d models i made in 3Dmax.

I've typed some code that basically takes one object from a 3d file and imports into another, and then tells it where to place itself within the new object/scene. It's parent child scene; in my case the study being the parent and the wasp being the child.

pWasp = member(pStudy).cloneModelFromCastMember("wasp", "wasp", member("wasp"))


pWasp.transform.scale = vector(.090,0.090,0.090)

pWasp.transform.position = vector(-150,-050,100)

pWasp.transform.rotation = vector(45,0,110)

Thats the code there. Now the problem comes after sometime running Director MX. I don't think is a Lingo script problem, becuase it does work, but only when i fist wrote and code and anytime i open the file.

After a few times compiling and running the code it seems to stop working for no reason what so ever!

Can anyone help?

  Mysticnas 21:17 19 Jan 04

Comes up as:

"Script error: Error

pWasp = member(pStudy).cloneModelFromCastMember("wasp", "wasp", member("wasp"))

-2147196928"


oops i think the code came out all funny in the 1st window.

pWasp = member(pStudy).cloneModelFromCastMember("wasp", "wasp", member("wasp"))


pWasp.transform.scale = vector(.090,0.090,0.090)


pWasp.transform.position = vector(-150,-050,100)


pWasp.transform.rotation = vector(45,0,110)

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Prehistoric Britain is laid out in these Royal Mail stamp illustrations

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…