Epson-XP750 to MAC printing problem

  DRDR1 19:22 28 Aug 14
Locked

I have a Mac desktop connected to an Epson XP-750 by Ethernet cable. Yesterday it worked perfectly, today it prints nothing. I have turned everything (including router) but it makes no difference. I have a Windows based laptop connected via WIFI and I can print from that. Anything I print from the Mac goes into the queue and remains there. The Print Utility shows 'offline', if I go into Print Settings' it says 'Communications Error'. Nothing has changed, the connecting cable has not been touched. I have tried the USB end in other sockets without success. In desperation I am about to reinstall the software, although I don't think it will solve the problem. Any ideas would be welcome

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now