emachine partial power failure

  Cockle 11:21 14 Jan 08
Locked

Only neon on front panel lights up, no power unit fan,no CPU fan.CPU fan works if I supply 12v from another power supply.motherboard has seperate 4pin 12v supply in addition to ATX powwer supply.

  Taff™ 12:01 14 Jan 08

Swap the PSU completely and see if the problem is resolved. If not the faulty PSU may have damaged the main board. Which model emachine is it by the way? What make was the original PSU?

  Cockle 10:16 15 Jan 08

Thank you Taff for your response, I have swapped PSU to one that is ok but result is the same, no 12v power,I also used defective PSU on another mainboard, again same results. I am beginning to believe both PSU and Motherboard are naff.The PC is an eMachine model 620. PSU Bestec 250w-modelATX-250-12e-REV52.
I run a Computer Forum for the over 50s so your input has been a great help as the PC is one of our members. Thanks , Cockle

  Taff™ 14:25 15 Jan 08

There was a problem with the Bestec Power supply in the eMachine 620 which is well documented. When it blows it takes out the motherboad too. It`s quite an old model now but I can assure you that if it`s like the one I tried to fix 18 months ago it`s a gonner. It will probably have blown your keyboard and mouse too. (Try them on another PC)

Anyone want a set of recovery discs and a manual for this machine by the way?

  Taff™ 14:57 15 Jan 08

click here

click here

Just a couple I could find quickly. Looks like a new system is what is required.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…