E-machine won't start

  Newbolt 10:49 08 Nov 08
Locked

My daughters e-machine 270 will not start. Carefully disconnected before room decoration. When all reconnected no life at all - no fan, lights or anything else. Cables, plug and sockets all ok, and power going to monitor. Is there a reset somewhere perhaps? All working perfectly before above sequence. Any suggestions would be much appreciated.

  chub_tor 10:59 08 Nov 08

Silly question but..... some power supplies have their own on/off switch on the back of the PC. You haven't turned it off have you?

  Newbolt 11:01 08 Nov 08

Thanks - the obvious thought is often the best one, but on this occasion I did check and there is no switch.

  woodchip 11:03 08 Nov 08

My very thoughts when I read above, a rocker switch may have been knocked at the back. If not then Try a New PSU

  Switcher 12:15 08 Nov 08

Have you checked the fuse in the plug

  Switcher 12:16 08 Nov 08

Have you tried a different socket

  Newbolt 17:16 08 Nov 08

Switcher, yes, thanks. Both checked, plus three different cables tried. An old machine in computer terms which prbably doesn't owe us very much, but some useful stuff on the hard disk still.

  Fruit Bat /\0/\ 17:28 08 Nov 08

With no signs of fans LEDs etc and the obvious checked
Sounds as if the PSU has died

  Fruit Bat /\0/\ 17:28 08 Nov 08

With no signs of fans LEDs etc and the obvious checked
Sounds as if the PSU has died

  Newbolt 18:21 08 Nov 08

Thanks for all responses. Next move being ondered - possibly place HD in another PC.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac