copying between internal drives kills my machine?

  jake williamson 17:21 16 Nov 03
Locked

i cant figure out this one...

i have two internal drives in my dell 8300: the main 60 giger has winXP home and the 2nd 80 giger is split into 2 40 gig partitions.

when i copy files between disks, download stuff from the net, ftp files the machine grinds to a hault and becomes very unresponsive. when i check the performance pannel it shows 100%.

this is a beefy machine - is there anything i can check? cant belive that the performance dips that much when doing simple copys...

any clues out there??

cheers,

jake

  Gongoozler 17:37 16 Nov 03

Hi jake. Copying or moving files between drives shouldn't slow a modern computer significantly. Check that both drives have DMA enabled.

  jake williamson 19:27 16 Nov 03

hi,

thanks for the suggestion.

i've gone into the device manager and the primary ide drive has:

device 0, device type: auto detection, transfer mode: DMA if available, current transfer mode: ultra dma mode 2.

device 1, device type: auto detection, transfer mode: DMA if available, current transfer mode: PIO mode.

the settings for secondry channel are the same for device 0 but device 1's current transfer mode is set to ultra dma mode 2.

weird! gonna have a play, but what would you suggest?

cheers,

jake

  Gongoozler 22:31 16 Nov 03

Hi jake. I think both drives should be set to DMA mode. PIO mode uses the cpu as part of the data path which will inevitably slow the computer down. You should also have the new 80 way ide cable for your hard drives, using the old 40 way cables will slow the transfer.

  jake williamson 10:05 17 Nov 03

think this must be it - the cpu usage zooms up when i use that drive...

thing is, it wont let me change it! i only get the DMA if available option but i cant change it from PIO to DMA.

is this something i need to do in the bios settings before the machine boots up??

cheers,

jake

  Gongoozler 10:18 17 Nov 03

Hi Jake. Yes this is probably a BIOS setting. Depending on what motherboard you have, you may have the option to enable DMA under the heading of "Standard CMOS Features" or "Main". I find that as long as the hard drive is set to "Auto", the BIOS usually sorts everything else out itself.

  jake williamson 11:59 29 Dec 03

hi, thanks for the reply. i had a good look through the link you posted and had a hunt on the dell forum.

in the end, it was in the bios. i checked out the settings under 'drive configuration'.

the primary master drive said hard drive. the primary slave drive said off. so i set this to auto and rebooted.

now the bios says hard drive and the current transfer modes on both hard drives is on 'ultra dma mode 5' - copying files is now soooper speedy!

thanks again,

jake

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

How VR is being used to simulate space

New iPad, iPhone SE & Red iPhone 7 on sale now