What’s up with telephone/online bank First Direct? Is it a true online enterprise or does it have a schizophrenic love/hate relationship with users of Apple Macs?

Just the other day it was shouting about how it had enhanced its internet banking service to offer a "seamless online experience” for all its customers using an iPhone or an iPod touch.

Bravo!

A few months later and its supposedly innovative online banking service suddenly works only with Windows PCs.

First Direct has launched a new service called Internet Banking Plus, which allows users to gather together all their online financial data in one place.

It’s had rave reviews, from the likes of InvestorProfit.com and ThisIsMoney.co.uk.

Sadly, Internet Banking Plus turns out to be something of a Minus.

When Mac users click onto the service, they are met with a frankly infuriating screen.

“oops! incompatible browser,” it says – as if saying “oops!” makes this glaring technical mistake rather amusing. I’m sure that Bill Gates would chuckle, but many of the bank’s customers will be spitting blood.

Imagine walking into a bank branch and being told to leave immediately because your kind aren't welcome. "Oops! Sod off, customer!".

Or what if a First Direct customer phoned up, and was told "Oops! You're using a cordless phone" before being rudely cut off?

“Internet banking plus uses technology that requires Internet Explorer version 5.0 and above on a PC. Unfortunately the service will not currently work using other internet browsers or Apple Mac computers,” says First Direct of its supposedly Plus service.

Old software only, please
To be fair, First Direct isn’t just being lame about not supporting Mac users. It doesn’t support Microsoft’s Windows Vista either! It's probably too modern. Now, you can stop smirking, Bill…

The bank recommends that its customers use an “IBM compatible PC” running either Windows 2000 Professional, XP Professional or XP Home Edition. Is First Direct the only orgainsation that still refers to Windows PCs as "IBM compatible PCs"? And Linux runs on IBM compatible PCs, but it's not included in First Direct's online banking party either.

Most important, its customers should forget about using popular browsers such as Firefox. To use Internet Banking Plus you must use Internet Explorer version 5.5 or 6 with ActiveX enabled.

So you can also forget about using up-to-date browsers, such as, say, Internet Explorer 7.

When pressed First Direct explained further:

“Unfortunately, it is not possible to access the Internet Banking Plus service using an Apple Mac computer. The service requires the use of certain ActiveX controls which (sic) allow your computer to make the Internet Banking Plus service a secure and highly interactive experience.

“In addition, the ActiveX controls are used to create a Digital Safe and run the functionality in the Internet Banking Plus service on the computer. At present, the Apple Mac operating system does not support the use of these ActiveX controls.

“We may review this at a later date.”

So is the bank telling us that the rest of its online banking system is unsafe because it doesn’t use ActiveX controls?

And what about that wonderful Apple iPhone service it has boasted about?

The iPhone uses Apple’s Safari browser. First Direct’s tech team clearly know how to code for that. But is that inherently unsafe, too?

Practise what you preach
Paul Say, head of e-marketing at First Direct, says the bank is “attracting the type of customer who was an eager user of online banking in the early days”.

Those early days being when Internet Explorer 5 and 6 were still current browsers, I suppose, and when none of its customers used Macs or Linux, or Firefox, etc.

First Direct's Head of Marketing, Mark Mullen, has even described himself as “a long-standing Mac devotee”.

What is a bank doing employing someone who is so reckless with his online security? Using a Mac, good grief! Escort him from the building immediately.

Darren Sugden, head of e-commerce at First Direct, launched the bank’s first podcast (yes, these guys really are trying to be hip and innovative) with a chat about staying safe online.

In it he gave some sage advice: “Try and keep (sic) your operating system up to date. We would recommend that on Windows you have 2000 or later and obviously for the Apple Mac users and Linux users keep an eye on their operating systems and make sure that you keep those up to date.”

Someone please tell Darren. Don’t you know that Macs and Linux computers are unsafe because they don’t have ActiveX controls?

And what’s all this about using up-to-date operating systems? Remember, First Direct recommends that its customers don’t use Windows Vista or Mac OS X Leopard, let alone OS X Tiger, etc.

Oops!